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Chapter 1: Adobe AIR Update for Flash 
CS3 Professional

The Adobe® AIR™ update for Adobe® Flash® CS3 Professional augments the authoring environment to allow you to 
create, debug, and package Adobe AIR applications with Flash. The process of creating an Adobe AIR application 
consists of creating an Adobe AIR FLA file, setting the appropriate publish settings, developing the application, and 
creating the application and installer files that allow you to deploy the application.
You can download the Adobe AIR update for Flash CS3 Professional at 
http://www.adobe.com/support/flash/downloads.html. 
For information on the Adobe AIR ActionScript™ APIs that you can use in your application, see the ActionScript 3.0 
Language and Components Reference. For a list of Adobe AIR ActionScript APIs, see the section on new functionality 
in Adobe AIR in Developing Adobe® AIR™ Applications with Adobe® Flash® CS3 Professional. 
Note: To use classes in the air.net package, first drag the ServiceMonitorShim component from the Components panel to 
the Library panel and then add the following import statement to your ActionScript 3.0 code:
import air.net.*;

Contents

• “Create an Adobe AIR file” on page 2
• “Setting Adobe AIR publish settings” on page 3
• “Preview an Adobe AIR application” on page 4
• “Debug an Adobe AIR application” on page 4
• “Creating AIR application and installer files” on page 4
• “Creating a custom application descriptor file” on page 9
• “Signing your application” on page 9

Create an Adobe AIR file
You can create Flash File (Adobe AIR) documents using the Flash Welcome screen or create a Flash File (Action-
Script™ 3.0) and convert it to an Adobe AIR file through the Publish Settings dialog box. You cannot create an Adobe 
AIR file, however, by using the New Document dialog box (File > New). For information on converting a Flash file 
to an Adobe AIR file, see “Setting Adobe AIR publish settings” on page 3. 
1 Start Flash or, if you have already started Flash, close any open documents to return to the Welcome screen.

Note: If you’ve disabled the Flash Welcome screen, you can display it again by selecting Edit > Preferences and 
selecting Welcome Screen from the On Launch pop-up menu in the General category.

2 On the Welcome Screen, click Flash File (Adobe AIR).
An alert dialog box appears to tell you how to access the Adobe AIR application settings and how to access the 
Help documentation. You can bypass this alert box in the future by selecting Don’t Show Me Again, but there 
is no way to make it appear again. 

http://www.adobe.com/go/learn_air_flash_en
http://www.adobe.com/go/learn_air_aslr_en
http://www.adobe.com/go/learn_air_aslr_en
http://www.adobe.com/go/learn_air_aslr_en
http://www.adobe.com/go/learn_air_aslr_en
http://www.adobe.com/support/flash/downloads.html
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Setting Adobe AIR publish settings
Use the Flash publish settings to examine or change the settings for an AIR file and to convert a Flash File (Action-
Script 3.0) document to a Flash File (Adobe AIR) document.

View Adobe AIR publish settings
1 From the Flash Welcome screen, open a Flash File (Adobe AIR) document.
2 Select File > Publish Settings and click the Flash tab to see the Adobe AIR publish settings.

Adobe AIR 1.0 is automatically selected in the Version menu when you open an Adobe AIR document. The 
ActionScript™ version is automatically set to ActionScript 3.0. The Local playback security setting is dimmed 
because it is irrelevant for an AIR SWF file.

If you opened a Flash FLA file, you can convert it to a Flash AIR file by changing the publish settings.

Convert a Flash FLA file to a Flash AIR file using the Publish Settings dialog box
1 Do one of the following:

• Open an existing Flash file. 
• Use the Welcome screen or select File > New to create a new Flash file.

2 Select File > Publish Settings.
3 On the Flash tab, select Adobe AIR 1.0 from the Version pop-up menu.

The ActionScript version entry is disabled because ActionScript 3.0 is the only option for an AIR file.
The remaining default options are the same for both a Flash file and an Adobe AIR file.

4 Click the Publish button, and then click OK to close the Publish Settings dialog box. The Property inspector now 
indicates that the Player target is Adobe AIR 1, when the Selection tool is selected. 

Note: When you choose the Adobe AIR 1.0 profile, Flash automatically adds the location of the AIR player-
global.swc file to the Classpath environment variable. The AIR playerglobal.swc file enables you to use the Action-
Script AIR APIs. If you switch from Adobe AIR 1 to Adobe® Flash® Player 9, however, Flash does not automatically 
revert to the default profile or change the Classpath setting to use the playerglobal.swc for Flash Player 9. If you 
change the publish setting from Adobe AIR 1 to Flash Player 9, you must change the publish profile to Default.

For additional information on the Publish Settings dialog box, see Using Flash at 
www.adobe.com/go/learn_fl_using. 

Convert a Flash FLA file to a Flash AIR application using the Commands menu
1 Open your Flash FLA file.
2 If you’re opening a new Flash File (ActionScript 3.0), save it. If you don’t save it, a warning appears when you do 
the next step.
3 Select Commands > AIR - Application And Installer Settings.

An alert box appears, asking if you want to convert the file to Adobe AIR publish settings.
4 Click OK to convert the FLA file to Adobe AIR publish settings. The AIR - Application And Installer Settings 
dialog box appears. 

For information on the AIR - Application And Installer Settings dialog box, see “Creating AIR application and 
installer files” on page 4.

You can use the Test Movie, Debug Movie, and Create AIR File commands on the converted AIR FLA file. 
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Preview an Adobe AIR application
You can preview a Flash AIR SWF file as it would appear in the AIR application window. Previewing is useful when 
you want to see what the visible aspects of the application look like without packaging and installing the application.
1 Make sure you’ve set the publish settings for an Adobe AIR application. For more information, see “Setting 
Adobe AIR publish settings” on page 3.
2 Select Control > Test Movie or press Control+Enter.

If you have not set application settings through the AIR - Application And Installer Settings dialog box, Flash 
generates a default application descriptor file (swfname-app.xml) for you in the same folder where the SWF file 
is written. If you have set application settings using the AIR - Application And Installer Settings dialog box, the 
application descriptor file reflects those settings.

Debug an Adobe AIR application
The Adobe AIR SWF file can be debugged just like a Flash Player 9 ActionScript 3.0 SWF file, except for remote 
debugging.
1 Make sure that you have set Adobe AIR publishing settings.
2 Add ActionScript code to the Actions panel (Window > Actions). For testing, you could simply add a trace() 
statement like the following one to the Actions panel, on the first frame of the Timeline:

trace("My application is running");

3 Select Debug > Debug Movie or Press Control+Shift+Enter.
Flash starts the ActionScript debugger and exports the SWF file with debug information.
If you have not set application settings through the AIR - Application And Installer Settings dialog box, Flash 
generates a default application descriptor (swfname-app.xml) file for you in the same folder where the SWF file 
is written. If you have set application settings using the AIR - Application And Installer Settings dialog box, the 
application descriptor file reflects those settings.
When you select Debug > Debug Movie or Press Control+Shift+Enter to debug your application, Flash displays 
an alert if your application does not include any ActionScript code.

Creating AIR application and installer files
After you’ve completed your application, create the AIR application and installer files to deploy it. Adobe AIR adds 
two new menu items to the Flash Commands menu: AIR - Application And Installer Settings and AIR - Create AIR 
File. After you have created the AIR application and installer settings, you can use the AIR-Create AIR File item to 
re-create the AIR (.air) file with the existing settings. 

Create the Adobe AIR application and installer files
1 In Flash, open the page or set of pages that make up your Adobe AIR application.
2 Save the Adobe AIR FLA file before you open the AIR - Application And Installer Settings dialog box.
3 Select Commands > AIR - Application And Installer Settings.
4 Complete the AIR - Application And Installer Settings dialog box, and then click Publish AIR File.
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When you click the Publish AIR File button, the following files are packaged: the FLA file, the SWF file, the 
application descriptor file, the application icon files, and the files listed in the Included Files text box. If you have 
not already created a digital certificate, Flash displays the Digital Signature dialog box when you click the 
Publish AIR File button.

The AIR - Application And Installer Settings dialog box is divided into two sections: Application Settings and 
Installer Settings. For more information on these settings, see the following sections.

Application settings
The Application settings section of the AIR - Application And Installer Settings dialog box has the following options:
File Name The name of the main file of the application. Defaults to the name of the SWF file.
Name The name used by the installer to generate the application filename and the application folder. The name must 
contain only valid characters for filenames or folder names. Defaults to the name of the SWF file.
Version Optional. Specifies a version number for your application. Defaults to blank. 
ID Identifies your application with a unique ID. You can change the default ID if you prefer. Do not use spaces or 
special characters in the ID. The only valid characters are 0-9, a-z, A-Z, . (dot), and - (dash), from 1 to 212 characters 
in length. Defaults to com.adobe.example.application_name.
Description Optional. Lets you enter a description of the application to display when the user installs the appli-
cation. Defaults to blank. 
Copyright Optional. Lets you enter a copyright notice to display when the user installs the application. 
Window Style Specifies what window style (or chrome) to use for the user interface when the user runs the appli-
cation on their computer. You can specify System Chrome, which refers to the visual style that the operating system 
uses. You can also specify Custom Chrome (opaque) or Custom Chrome (transparent). To display your application 
without the system chrome, select None. System Chrome surrounds the application with the operating-system 
standard window control. Custom Chrome (opaque) eliminates the standard system chrome and lets you create a 
chrome of your own for the application. (You build the custom chrome directly in the FLA file.) Custom Chrome 
(transparent) is like Custom Chrome (opaque), but it adds transparent capabilities to the edges of the page. These 
capabilities allow for application windows that are not square or rectangular in shape.
Icon Optional. Lets you specify an icon for the application. The icon is shown after you install the application and 
run it in Adobe AIR. You can specify four different sizes for the icon (128, 48, 32, and 16 pixels) to allow for the 
different views in which the icon appears. For example, the icon can appear in the file browser in thumbnail, detail, 
and tile views. It can also appear as a desktop icon and in the title of the AIR application window, as well as in other 
places. 
Defaults to the AIR application icon if no icon files are specified.
To specify an icon, click the Select Icon Images button in the AIR - Application And Installer Settings dialog box. In 
the Icon images dialog box that appears, click the folder for each icon size and select the icon file to use. The files 
must be in PNG (Portable Network Graphics) format.
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The following illustration shows the Icon Images dialog box with the default Adobe AIR application icons. 

Specifying different sizes of application icon images

If you specify an image, it must be of the size that you specify (128x128, 48x48, 32x32, or 16x16), or the application 
installation fails. If you do not specify a file for a particular size, Adobe AIR uses the image of the closest size and 
scales it to fit for the given occurrence. 

Advanced Settings

The Settings button in the AIR - Application And Installer Settings dialog box allows you to specify advanced 
settings for the application descriptor file. When you click the Settings button, the Advanced Settings dialog box 
appears.
The Advanced Settings dialog box lets you specify any associated file types that the application should handle. For 
example, if you wanted your application to be the principal application for handling HTML files, you would specify 
that in the Associated File Types text box. 
You can also specify settings for the following aspects of the application: 
• The size and placement of the initial window
• The folder in which the application is installed 
• The Program menu folder in which to place the application. 
The dialog box has the following options:
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Associated file types Lets you specify associated file types that the AIR application will handle. Click the Plus (+) 
button to add a new file type to the text box. Clicking the Plus button displays the File Type Settings dialog box. 
Clicking the Minus (-) button removes an item that is selected in the text box. Clicking the Pencil button displays the 
File Type Settings dialog box and allows you to edit an item that you’ve selected in the text box. By default, the Minus 
(-) and Pencil buttons are dimmed. Selecting an item in the text box enables the Minus (-) and Pencil buttons, 
allowing you to remove or edit the item. The default value in the text box is None. 
For more information on the file type settings for associated file types, see “File type settings” on page 7.
Initial window settings Lets you specify size and placement settings for the initial application window. 
• Width: Specifies the initial width of the window in pixels. The value is blank by default.
• Height: Specifies the initial height of the window in pixels. The value is blank by default.
• X: Specifies the initial horizontal position of the window in pixels. The value is blank by default.
• Y: Specifies the initial vertical position of the window in pixels. The value is blank by default.
• Maximum Width and Maximum Height: Specify the maximum size of the window in pixels. These values are 
blank by default.
• Minimum Width and Minimum Height: Specify the minimum size of the window in pixels. These values are 
blank by default.
• Maximizable: Lets you specify whether the user can maximize the window. This option is selected (or true) by 
default.
• Minimizable: Lets you specify whether the user can minimize the window. This option is selected (or true) by 
default.
• Resizable: Lets you specify whether the user can resize the window. If this option is not selected, Maximum 
Width, Maximum Height, Minimum Width, and Minimum Height are dimmed. This option is selected (or true) by 
default.
• Visible: Lets you specify whether the application window is visible initially. The option is selected (or true) by 
default.
Other Settings Lets you specify the following additional information regarding the installation:
• Install Folder: Specifies the folder in which the application is installed.
• Program Menu Folder: Specifies the name of the program menu folder for the application. 
• Custom Update UI: Specifies what happens when a user opens an AIR file for an application that’s already 
installed. By default, AIR displays a dialog box that allows the user to update the installed version with the version 
in the AIR file. If you don’t want the user to make that decision and you want the application to have complete control 
over its updates, select this option. Selecting this option overrides the default behavior and gives the application 
control over its own updates. For information on updating an AIR application programmatically, see the section on 
updating AIR applications programmatically in Developing Adobe® AIR™ Applications with Adobe® Flash® CS3 Profes-
sional.

File type settings

Flash displays the File Type Settings dialog box if you click the Plus (+) button or the Pencil button in the Advanced 
Settings dialog box to add or edit associated file types for the application.
The only two required fields in this dialog box are Name and Extension. If you click OK and either of those fields is 
blank, Flash displays an error dialog box.
You can specify the following settings for an associated file type:
Name The name of the file type (for example, Hypertext Markup Language, Text File, or Example).
Extension The filename extension (for example, html, txt, or xmpl), up to 39 basic alphanumeric characters, (A-Za-
z0-9), and without a leading period.

http://www.adobe.com/go/learn_air_flash_en
http://www.adobe.com/go/learn_air_flash_en


ADOBE AIR 1
Developer Guide

8

Description Optional. A description of the file type (for example, Adobe Video File).
Content type Optional. Specifies the MIME type for the file.
File Type Icon Settings Optional. Lets you specify an icon that’s associated with the file type. You can specify four 
different sizes for the icon (128x128, 48x48, 32x32, and 16x16 pixels) to allow for the different views in which the 
icon appears. For example, the icon can appear in the file browser in thumbnail, detail, and tile views. 
If you specify an image, it must be of the size that you specify. If you do not specify a file for a particular size, AIR 
uses the image of the closest size and scales it to fit for the given occurrence. 
To specify an icon, either click the folder for the icon size and select an icon file to use or enter the path and filename 
for the icon file in the text box next to the prompt. The icon file must be in PNG format.
After a new file type is created, it is shown in the File Type list box in the Advanced Settings dialog box.

Application descriptor file settings

The application settings that you specify are saved to the application_name-app.xml file. You have the option, 
however, of indicating to Flash that you want to use a custom application descriptor file. 
Use Custom Application Descriptor File Lets you browse to a custom application descriptor file. If you select Use 
Custom Application Descriptor File, the Application Settings section of the dialog box is dimmed. To specify the 
location of the custom application descriptor file, either enter it in the text field below Use Custom Application 
Descriptor File or click the folder icon and browse to the location. For more information on the application 
descriptor file, see “Creating a custom application descriptor file” on page 9.

Installer settings 
The second section of the AIR - Application And Installer Settings dialog box contains settings that pertain to 
installing the application.
Digital Signature All Adobe AIR applications must be signed to be installed on another system. For information 
about assigning a digital signature to a Flash Adobe AIR application, see “Signing your application” on page 9. 
Destination Specifies where to save the AIR file. The default location is the directory where you saved the FLA file. 
Click the folder icon to select a different location. The default package name is the application name with the .air file 
extension.
Included Files/Folders Specifies which additional files and folders to include in your application. Click the Plus (+) 
button to add files, and the folder button to add folders. To delete a file or folder from your list, select the file or folder 
and click the Minus (-) button. 
By default, the application descriptor file and the main SWF file are automatically added to the package list. The 
package list shows these files even if you have not yet published the Adobe AIR FLA file. The package list displays 
the files and folders in a flat structure. Files in a folder are not listed, and full path names to files are shown but are 
truncated if necessary.
Icon files are not included in the list. When Flash packages the files, it copies the icon files to a temporary folder that 
is relative to the location of the SWF file. Flash deletes the folder after packaging is complete. 

Failure to create application and installer files
The application and installer files fail to be created in the following instances:
• The application ID string has an incorrect length or contains invalid characters. The application ID string can 
be from 1 to 212 characters and can include the following characters: 0-9, a-z, A-Z, . (dot), - (hyphen).
• Files in the installer list do not exist.
• The sizes of custom icon files are incorrect.
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• The AIR destination folder does not have write access.
• You have not signed the application or have not specified that it is an Adobe AIRI application that will be signed 
later.

Creating a custom application descriptor file
The application descriptor file is an XML file that you can edit with a text editor. To create a custom application 
descriptor file, edit the values to specify the values you want. The default values are shown here:
• id = com.adobe.example.swfname
• fileName = swfname
• name = swfname
• version = 1.0
• description = blank
• copyright = blank
• initialWindow

• title = name
• content = swfname.swf
• systemChrome = standard, type = normal
• transparent = false
• visible = true

• icon
• image128x128 = icons/AIRApp_128.png
• image48x48 = icons/AIRApp_48.png
• image32x32 = icons/AIRApp_32.png
• image16x16 = icons/AIRApp_16.png

• customUpdateUI = false
• allowBrowserInvocation = false
For more information on the application descriptor file, see the section on setting application properties in Devel-
oping Adobe® AIR™ Applications with Adobe® Flash® CS3 Professional.

Signing your application
All Adobe AIR applications must be signed to be installed on another system. Flash provides the ability, however, to 
create unsigned Adobe AIR installer files so that the application can be signed later. These unsigned Adobe AIR 
installer files are called an AIRI package. This capability provides for cases in which the certificate is on a different 
machine or signing is handled separately from application development.

Sign an Adobe AIR application with a pre-purchased digital certificate from a root certificate authority
1 Click the Digital Signature Set button in the AIR - Application And Installer Settings dialog box. The Digital 
Signature dialog box opens. 

http://www.adobe.com/go/learn_air_flash_en
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This dialog box has two radio buttons that allow you to either sign your Adobe AIR application with a digital 
certificate or prepare an AIRI package. If you sign your AIR application, you can either use a digital certificate 
granted by a root certificate authority or create a self-signed certificate. A self-signed certificate is easy to create 
but is not as trustworthy as a certificate granted by a root certificate authority. 

Digital Signature dialog box for signing an AIR application

2 Select a certificate file from the pop-up menu or click the Browse button to locate a certificate file.
3 Select the certificate. 
4 Enter a password.
5 Click OK.
For information on signing your AIR application, see the section on digitally signing an AIR file in Developing 
Adobe® AIR™ Applications with Adobe® Flash® CS3 Professional.

Create a self-signed digital certificate
1 Click the Create button. The Self-Signed Digital Certificate dialog box opens.
2 Complete the entries for Publisher Name, Organization Unit, Organization Name, Country, Password, and 
Confirm Password.
3 Specify the type of certificate. 

The Type option refers to the level of security that the certificate carries: 1024-RSA uses a 1024-bit key (less 
secure), and 2048-RSA uses a 2048-bit key (more secure). 

4 Save the information in a certificate file by completing the Save As entry or clicking the Browse button to browse 
to a folder location.
5 Click OK.
6 In the Digital Signature dialog box, enter the password you assigned in the second step of this procedure and 
click OK.
After you have set a digital certificate, the Set button changes to a Change button.
To have Flash remember the password you used for this session, click Remember Password For This Session. 

http://www.adobe.com/go/learn_air_flash_en
http://www.adobe.com/go/learn_air_flash_en
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If the Timestamp option is unselected when you click OK, a dialog box warns that the application will fail to install 
when the digital certificate expires. If you click Yes in response to the warning, timestamping is disabled. If you click 
No, the Timestamp option is automatically selected and timestamping is enabled.
For more information on creating a self-signed digital certificate, see the section on digitally signing an AIR file in 
Developing Adobe® AIR™ Applications with Adobe® Flash® CS3 Professional.You can also create an AIR Intermediate 
(AIRI) application without a digital signature. A user cannot install the application on a desktop, however, until you 
add a digital signature.

Prepare an AIRI package that will be signed later
❖ In the Digital Signature dialog box, select Prepare An AIRI Package That Will Be Signed Later, and click OK.

The digital signature status changes to indicate that you have chosen to prepare an AIRI package that will be 
signed later, and the Set button changes to a Change button.

http://www.adobe.com/go/learn_air_flash_en
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